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Introduction
SuperLogic Pro is a graphical and feature-rich ladder-logic programming environment for 
the Smart3G cards that is developed to meet industrial programming standards for many 
specialized applications. Operation-wise, the SuperLogicPro application also serves  
as the direct interface to the connected Smart3G card.

Features:

	 •   Create robust, powerful, and reusable ladder-logic programs  
	      and download them to cards

	 •   Upload and Modify existing ladder-logic programs straight from a Smart3G card

	 •   Monitor and debug program execution during runtime

	 •   Temporarily change Ladder Files contents while monitoring without altering rungs

	 •   Drag-and-drop Graphical User Interface for simple,  
	      yet extensive ladder-logic programming

1.1
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2.1

Menu Bar Overview
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2.2

Ladder Editor

The Ladder Editor is where ladder programs are edited and monitored. This window can be 
accessed by Double-Clicking a ladder program node under “Ladder Programs” in the Project 
Explorer, or by creating a new Ladder Program.

To create a new Ladder Program:

	 1   Right-Click on the “Ladder Programs” node in the Project Explorer

	 2   Select “Add New”

	 3   Input a valid Ladder Program Name (this can be changed later on)

	 4   Confirm

The Ladder Editor for a ladder program is also automatically opened when monitoring  
is enabled from the Project Explorer, or the Icons Menu Bar.

Note: When modifying a contact, it can almost always be done from the Property Window. 
It is also possible to copy and paste rungs and contacts between multiple Ladder Editors.
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2.3

Project Explorer Window
The Project Explorer Window is the basic navigation  
and management window for the application. It can be  
accessed from the View Menu or by clicking the Project  
Explorer Icon under the Menu Bar.

The Project Explorer diplays:

	 •   The current active project

	 •   The Ladder Program on the active project

	 •   The Ladder Subroutines on the active project

	 •   The Tag Database for creating any form  
	      of text definitions

	 •   The Text Database where Smart3G serial barcodes  
	      can be defined

Toolbox Window
The Tool Box contains the needed tools and actions  
for creating a ladder program. Adding contacts, rungs,  
or branches, etc. can be done from here.

The Tool Box can be accessed from the View Menu,  
or by clicking the Tool Box Icon under the Menu Bar.

For a list of available commands,  
see Ladder Commands (Chaper 4).
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2.4

Properties Window
The Properties Window displays the properties  
for each command in the Ladder Program Editor.

It can be accessed by Right-Clicking inside a Ladder  
View and Selecting “Properties”, from the View Menu,  
or by clicking the Property Window Icon under  
the Menu Bar.

Debug Window

The Debug Window displays compilation errors for the ladder program (if there are any)  
after the compilation process. Error entries can be clicked to jump to the source of the error.  
The Debug Window can be accessed by clicking the Debug Window Icon under the menu bar, 
otherwise it pops-up when errors are detected after compiling a Ladder Program.

Output Window

The Output Window provides detailed and technical feedback such as application  
log messages, compile messages, and errors. The Output Window can be accessed  
by clicking the Output Window Icon under the menu bar, otherwise it pops-up  
automatically when necessary.

Note: Modification is disabled when the ladder program is being monitored.
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2.5

Device Status Window

The Ladder Status window displays general information about the target device, as well as  
its files. The current values may be viewed in this window if there is a connection is present.  
The user may also change the file values from this window, which provides a degree  
of manual control on the execution of the ladder program.

The Status Window can be accessed by clicking on the Status Window icon  
under the menu bar.
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Tag Database Window

SuperLogic Pro supports user-defined tags that can be substituted in place of the standard  
file addressing of the Ladder-Logic syntax. These definitions are created and modified in  
the Tag Database Window. The Tag Database Window can be accessed by double-clicking 
the “Tag Database” node in the Project Explorer.

Creating a tag has the following parameters:

	 •   Name – The definition mask over the real value of the tag

	 •   Value – The real file address in correct Ladder-Logic syntax

	 •   Comment

Advantages of using tags:

	 •   More descriptive file addressing

	 •   If you are using a tag multiple times in the ladder program, you can simply change  
	      the value in the Tag Database Editor once and it will affect all commands  
	      using the tag

	 •   Message Formats can be defined using tags

2.6
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2.7

Cross Reference

The Cross Reference View provides a list of which Device Files and Defined Tags are  
used in the current project. It also lists which rung and Ladder Program is referencing  
the file, device, or tag.
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3.1

Smart3G PLC devices support multiple addressable file types of which are:

	 •   Signed 32-bit Integers

	 •   Signed 32-bit Floats (floating point value)

	 •   Bits (1 or 0)

	 •   Timers

	 •   Counters

	 •   Barcode text strings

	 •   Etc.

Below is a more detailed explanation for each of these files.

LEGEND

Integer Register

Note: The following information was written based on version 7.14  
of the Smart3G firmware.
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3.2

Float Registers

Binary Registers
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3.3

Timer Registers

Counter Registers
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3.4

Inputs

Outputs

Control Words
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Control Bits

3.6



REV A SuperLogic Pro - User & Troubleshooting Guide

3www.poweredbyTrew.com

SYSTEM FILES

Barcode

3.7
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A Ladder Program is comprised of multiple rungs that are executed from top to bottom.  
Each rung is comprised of two types of commands, namely the inputs and outputs.

Input commands are used to evaluate if the state of the rung (active or not) which affects  
the execution of the output commands.

Output commands are commands that carry out actions in the ladder program such as writing 
to file values. Some output commands are not executed if the rung is inactive, while others  
will simply behave in a different manner.

Normally Open Command

Normally Closed Command

4.1



REV A SuperLogic Pro - User & Troubleshooting Guide

4www.poweredbyTrew.com

LADDER COMMANDS

Compare Command

4.2
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Text (Barcode) Lookup Command

4.3
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Output Command

4.4
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Timer / Counter Command

4.5
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Move Command

Send Message Command

4.7
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Math Command

4.8
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Reset Command

Ladder Subroutine Command

4.9
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Creating your First Ladder Program

	 1   Click File, then New Project. You should then see the screen below

5.1
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5.2

	 2   You may now start editing your new Ladder Program. You can create the first rung,  
	      as well as add contacts from the Toolbox Window (Accessible from the View Toolbox  
	      Menu circled in red). Click on the Thumb-pin of the Toolbox window to make it visible  
	      all the time

	 3   You may give the project a name when you save it. From the Menu Bar,  
	      click File -> SaveAs
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Importing a (.prg) Ladder Program
Instead of creating a ladder program from scratch, SuperLogic Pro can also import  
older Ladder Logic programs (.prg files). This can be done the same way as opening  
any ladder project.

	 1   On the main menu, click File -> Open Project

	 2   Select a (.prg) ladder program to open

5.3
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	 3   Imported (.prg) programs will most probably require a few conversions,  
	      some of which are performed automatically

5.4
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Runtime Operation
Although SuperLogic Pro can compile  
Ladder-Logic programs, running them  
requires a connection to a Smart3G Device.

Click the Connect Button (circled in red)  
to setup a connection. A window with  
Connection Parameters will appear.  
Set the necessary values for the specified  
fields then click on “Connect”.

The Adapter IP entry defines on which  
network the Smart3G device is located.  
This setting can be changed for PCs  
with more than one network adapter.

The Device ID entry determines which Smart3G device SuperLogic Pro will connect to.

Poll Frequency determines the interval (in milliseconds) to request monitoring data  
from the Smart3G device.

If the connection attempt is successful, you are given the option to then “Download”  
your current project on the Smart3G Device, or “Upload” the running project  
from the Smart3G device.

	 •   Download – Installs the current project on the Smart3G device. After downloading  
	      the project, the ladder program can then be started by clicking on the “Run Ladder  
	      Program” button. Additionally, the Smart3G device will now always run the ladder  
	      program on power-up.

	 •   Upload – Retrieve the project from the Smart3G device

Note: Before attempting a connection, make sure that the Smart3G device is connected 
to the network and is not in an error state (such as conflicting IP Address).

5.5
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Barcode Lookups

	 1   Barcode Lookups first require a barcode table where the lookup can be performed.  
	      To do this, go to the Project Explorer and right-click the “Barcode Database”  
	      and select Add

	

	 2   Enter a name for the new barcode table then click OK to create  
	      the new barcode table

Note: Make sure the Barcode scanner is set to Baudrate=38400, DataBits=8, Parity=None, 
StopBits=1, and CR or LF is sent at the end of the barcode string. Host ID in the 3G config 
should be set to None in order to use the on-board lookup feature. The Baudrate on the 
3G card can be modified by writing the Baud value divided by 100 to CW:5, e.g., for 9600 
baud, write 96 to CW:5. Other port settings are fixed at 8 bits, No Parity, 1 Stop Bit.

5.6
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	 3   A new entry should appear under the Barcode Database for the new barcode table.  
	      Double-click it to open the new barcode table. Barcodes can be added and removed  
	      from here. Once the barcode table has all the necessary entries, it can now be used  
	      within the ladder program

	 4   To use the new barcode table, it will need to be referenced by a “Lookup Contact”.  
	      Add a Lookup Contact in the ladder program (from the toolbox)

Note: Even though SuperLogic allows creating multiple barcode tables, only one  
Barcode Table can be searched by default. The “Extended Barcode Table Lookup”  
feature is required for using multiple barcode tables in the Smart3G device.  
Please Contact www.vsys.co to purchase the Extended Barcode Feature Activation.

Note: It’s always recommended to unlatch CB:10 in order to allow the 3G card to 
receive new barcodes. If CB:10 is left ON, then the Smart3G device will NOT receive 
any new barcode data.

5.7
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	 5   Click on the new Lookup Contact and check its properties from the Properties  
	      Window. The Lookup Contact requires a LookupTarget, which is any barcode table  
	      from the current project, where the lookup will be performed. A Start Index  
	      and Length may also be specified if only a part of the barcode string is required  
	      to perform the lookup

Examples:

This example will check if the current 
barcode is defined as an entry  
in “BarcodeTable1”.

This example will check if all the 
remaining characters, after the 
4th character of the barcode 
string is a text entry defined in 
“BarcodeTable1”.

This example will check if the next 4 
characters, after the 4th character 
of the barcode string, is a text entry 
defined in “BarcodeTable1”.

5.8
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	 6   Whenever a scanned barcode is present in the Smart3G device, the lookup contact  
	      will check the barcode table and see if the scanned barcode is contained within.  
	      If the scanned barcode is defined inside the barcode table, then the contact’s state  
	      becomes true, and false if not. Multiple barcode tables can be utilized in order  
	      to perform certain functions depending on the scanned barcode.

Note: When using serial scanners (e.g. barcode scanning), CB:10 must be 
unlatched in order to receive new serial data. Failure to unlatch CB:10 will result  
in new serial data being ignored by the 3G Device.

5.9
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Barcode Comparison
Specific regions of text in the barcode string can be checked via the compare command.  
See Barcode file type.

Example:

BAR:0,2 indicates that the first 2 characters of the barcode string are what will be  
used for the compare operation. Therefore, if a barcode which begins with “1Z”, or “1z”  
(because IgnoreCase has been set to true) is received, then the compare contact  
will evaluate to an active state.

Note: This feature requires the “Extended Lookup” activation and will defult  
to FALSE if CB:10 is NOT ACTIVATED.

5.10
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What do enabled/disabled rungs and contacts do?
By default, all rungs and contacts are enabled for the ladder program.  
This means that they are included in the ladder code compilation.

The “Enabled” setting for a contact or rung can be toggled from the Property Window.  
Setting “Enabled” to false disables the contact.

Setting a contact as disabled tells the compiler to ignore this contact and exclude it from the 
compiled ladder program. Disabled input contacts are treated as short contacts while disabled 
outputs are ignored. Disabled rungs, on the other hand, tell the compiler to ignore every 
contact regardless if the contacts themselves are enabled.

This feature comes in handy if you wish to temporarily exclude (without deleting the  
rung or contact itself) certain elements of the ladder program for debugging purposes.

5.11
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What are Ladder Subroutines and how do I use them?
A Ladder Subroutine is a type of Ladder Program that only needs to be created once  
and can be used multiple times in a Ladder Program as well as in multiple Ladder Programs.  
The use of subroutines can greatly minimize programming time due to the use of generic code.

Unlike normal ladder programs, subroutines cannot be directly executed, but rather, they are 
executed from within a true ladder program. Subroutines have access to all registers and files 
as the main program.

To use a Ladder Subroutine in an existing Ladder Program, you must first create the Ladder 
Subroutine Template.

	 1   Right Click on the “Subroutine Templates” folder in the Project Explorer  
	      and select “Add New”

	 2   Enter the name for your new Subroutine and click OK

5.12
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	 3   After creating your Subroutine Template, you may now create a subroutine  
	      instance from within an existing ladder program. This can be done by adding  
	      a ladder subroutine command (from the Toolbox)

	 4   Select the new contact and view its properties. Give your new subroutine  
	      instance a new Call Name (this value must be unique across the entire project)  
	      in the CallName property. In the LadderSubroutine property, you should  
	      see a drop down list of all your Ladder Subroutine Templates.  
	      Select the one you wish to use

	 5   You can make any number of subroutine instances in your Main Ladder  
	      Program now. Any changes you make to the Ladder Subroutine Template  
	      will reflect on all its instances

5.13
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Support
If you need further assistance: 

Website:
www.poweredbyTrew.com 

Email:
info@trewautomation.com

Phone:
1.800.571.8739 

Monday - Friday, 8:00am - 5:00pm CT


